Excel: fonction NB.SI – compter les cellules qui répondent à un critère



La fonction NB.SI peut être utilisée dans beaucoup de situations dans Excel. Elle permet de compter le nombre de cellules dans une plage donnée qui correspondent à un critère donné. Ce critère peut être un chiffre, un mot, la valeur d'une cellule ou encore une comparaison.

La syntaxe de la fonction NB.SI dans Excel

La fonction Excel NB.SI a une syntaxe très simple et ne contient que deux paramètres.

=NB.SI(plage_de_cellules; condition_a_remplir)

 

Les paramètres de la fonction NB.SI

  • plage_de_cellules : Les cellules danc lesquels le décompte est effectué. La plage de cellules peut être indiquée sous la forme d'adresse (ex. A1:C150) ou en tant que plage nommée (ex. MesValeurs).
  • condition_a_remplir : Cet argument contient la condition qui détermine quelle cellule sera prise en compte dans le comptage. L'argument peut contenir un nombre, une expression, une référence de cellule ou encore une chaîne de texte. L'utilisation de cet argument est détaillée dans la section qui suit.

La fonction NB.SI en pratique

Après un peu de théorie, on va rentrer dans du concret – l'utilisation en pratique de la fonction excel NB.SI.

Les conditions à utiliser dans la fonction NB.SI

Comme expliqué plus haut, vous pouvez utiliser plusieurs types de conditions comme argument de la fonction NB.SI. En voici l'aperçu:

  • nombre exact: par exemple "95". Ceci va compter les cellules dont la valeur est égale à 95. =NB.SI(A1:A100;"95")
  • comparaison numérique: par exemple "<100". Une telle formule comptera les cellules qui contiennent un chiffre qui est inférieur à 100. =NB.SI(A1:A100;"<100")
    Remarque: ceci peut s'appliquer également aux dates. Exemple: compter les cellules contenant les dates passées =NB.SI(A1:A100;"<"&AUJOURDHUI())
  • texte exact: par exemple "Pierre". Compte le nombre de cellules qui contiennent le texte exact "Pierre". =NB.SI(A1:A100;"Pierre")
  • texte avec les caractères génériques: le caractère "?" remplace exactement un caractère, le caractère "*" remplace un nombre indéfini de caractères. Par exemple la condition "*FR-??" comptera toutes les cellules qui se terminent par "FR-" suivi de deux caractères (quelque soient-ils). Le nombre de caractères avant le "FR-" n'a pas d'importance. =NB.SI(A1:A100;"*FR-??")
  • référence à une cellule: par exemple "B4". De cette manière, la fonction NB.SI comptera toutes les cellules dont le contenu est égal au contenu de la cellule "B4". =NB.SI(A1:A100;B4)

À quoi faire attention lors de l'utilisation de la fonction NB.SI

Même si NB.SI est plutôt facile à utiliser, il convient de faire attention à certains points qui peuvent créer des problèmes.

  • L'argument contenant la condition de comptage (condition_a_remplir) doit impérativement se trouver entre guillemets. Même s'il s'agit des conditions numériques ( "5" ) ou des expressions qui contiennent un opérateur de comparaison ( "<10" ).
  • Si vous voulez utiliser une condition textuelle qui utilise une longue chaîne de caractères (plus de 255 caractères), la fonction va renvoyer une erreur à la place de résultat. Mais il est possible de contourner cette limitation: il suffit de séparer le long texte en parties plus petites (avec moins de 255 caractères chacune) que l'on "recompose" ensuite grâce à l'opérateur de concaténation ( & ).
    Exemple: =NB.SI("A1:A1000";"première ... partie" & "seconde ... partie")

Exemples d'utilisation de la fonction NB.SI

Le grand classique n°1: "Compter le nombre de cellules vides dans Excel"

Vous obtiendrez le résultat souhaité grâce à la formule: =NB.SI(A1:A100;"=") ou =NB.SI(A1:A100;"")

Le grand classique n°2: "Compter le nombre de cellules non-vides dans Excel"

De la même manière, les cellules non vides peuvent être comptées avec la formule =NB.SI(A1:A100;"<>")

Le grand classique n°3: "Compter le nombre de cellules qui contiennent du texte"

Grâce à la fonction NB.SI, vous pouvez facilement trouver le nombre de cellules contenant du texte: =NB.SI(A1:G4;"*")

 

Et voici d'autres exemples de la fonction NB.SI…

Excel: fonction NB.SI - exemples

 


Pour aller plus loin…

Et si vous voulez explorer un peu plus les possibilités que vous offre Excel, voici quelques liens…

N'hésitez pas à partager cette page si elle vous a été utile et vous pouvez également laisser un commentaire en cas de questions, remarques ou idées d'amélioration…

 

10 0

 

Pourrait vous intéresser

Partagez cette page...
Share on FacebookShare on Google+Share on LinkedInTweet about this on TwitterShare on RedditShare on TumblrDigg thisEmail this to someone

Laissez un commentaire

Votre adresse de messagerie ne sera pas publiée.