Maîtrisez SOMME.SI en Excel: GUIDE COMPLET avec Exemples

La fonction Excel SOMME.SI peut être utilisée dans beaucoup de situations dans le tableur de Microsoft. Elle permet d'additionner les cellules dans une plage donnée qui correspondent à un critère donné. Ce critère peut être un chiffre, un mot, la valeur d'une cellule ou encore une comparaison.

La syntaxe de la fonction dans Excel

La fonction Excel SOMME.SI a une syntaxe assez simple qui contient trois paramètres dont un est optionnel.
=SOMME.SI(plage_de_cellules; condition_a_remplir; plage_a_additionner)

Les paramètres de la fonction SOMME.SI

  • plage_de_cellulesPlage de cellules à additionner en fonction du critère (condition_a_remplir). La plage de cellules peut être indiquée sous la forme d'adresse (ex. B1:B100) ou en tant que plage nommée (ex. MesValeurs). Cet argument est obligatoire.
    En gros: Si l'argument plage_a_additionner est utilisé, la plage_de_cellules sert uniquement à évaluer le critère. Ses cellules ne seront pas additionnées. Si en revanche plage_a_additionner n'est pas utilisé, la plage_de_cellules sert à déterminer le critère et ce sont ses valeurs qui seront additionnées! Voir les exemples et explications plus bas.
  • condition_a_remplir : Cet argument contient la condition qui détermine quelle cellule sera prise en compte dans l'addition. L'argument peut contenir un nombre, une expression, une référence de cellule, une date ou encore une chaîne de texte. L'utilisation de cet argument est détaillée dans la section qui suit. Cet argument est obligatoire.
  • plage_a_additionner : Cellules à additionner si vous voulez utiliser une plage de cellules pour vérifier si le critère est rempli (plage_de_cellules) et une autre plage pour additionner les valeurs (plage_a_additionner).
    Si l’argument plage_a_additionner est omis, Excel additionne les cellules spécifiées dans l’argument plage_de_cellules (pour lesquelles condition_a_remplir est rempli). Voir les exemples et explications plus bas. Cet argument est facultatif.

Pour information: l'équivalent en anglais de la fonction SOMME.SI est SUMIF

Détails des arguments de la fonction SOMME.SI (cliquez pour afficher)
Fonction Excel SOMME.SI: argument PLAGE
Fonction Excel SOMME.SI: argument “PLAGE”

 

Fonction Excel SOMME.SI: argument CRITÈRE
Fonction Excel SOMME.SI: argument “CRITÈRE”

 

Fonction Excel SOMME.SI: argument SOMME_PLAGE
Fonction Excel SOMME.SI: argument “SOMME_PLAGE”

La fonction SOMME.SI en Exemples Pratiques

Après un peu de théorie, on va rentrer dans du concret – l'utilisation en pratique de la fonction Excel SOMME.SI.

Les deux cas d'utilisation de la fonction SOMME.SI

  1. Additionner les nombres selon leur valeur
    Ceci est l'utilisation la plus simple. Vous additionnez simplement des valeurs qui correspondent à une valeur ou à une comparaison. Par exemple la somme des cellules qui contiennent le chiffre 100. Ou la somme des nombres inférieurs à 1000…
    Dans ce cas, vous avez besoin uniquement des deux premiers arguments de la fonction SOMME.SI, c'est à dire plage_de_cellules et condition_a_remplir. Le troisième argument (plage_a_additionner) ne sera pas utilisé.
    Voici quelques exemples:SOMME.SI: utilisation de base
  2. Additionner les nombres selon une valeur correspondante
    Dans ce cas-ci, vous additionnez les valeurs qui correspondent à une condition qui se trouve dans une autre plage de cellules. Souvent, vous avez une colonne avec les valeurs à tester et une autre colonne avec des valeurs à additionner au cas où la condition est remplie. Vous avez donc besoin d'utiliser les trois arguments de la fonction SOMME.SI. Voici des exemples d'utilisation de la formule. Sachez que, dans cet exemple, les valeurs à tester se trouvent dans la colonne "B" et les valeurs à additionner dans la colonne "C".
    Les critères (comparaisons) utilisés peuvent être de différent type: textes, dates ou encore des nombres…
    Voici donc des exemples…Fonction SOMME.SI: conditions texte
    Excel SOMME.SI: conditions dates
    SOMME.SI: conditions nombres

 

Comment utiliser les conditions dans la fonction SOMME.SI

Comme expliqué plus haut, vous pouvez utiliser plusieurs types de conditions comme argument de la fonction SOMME.SI. En voici l'aperçu:

  • nombre exact: par exemple "1000". Ceci va additionner les cellules dont la valeur est égale à 1000. =SOMME.SI(A1:A100;"1000")
    Sachez que pour plus de lisibilité, vous pouvez ajouter le signe "=". Ce qui donnerait alors =SOMME.SI(A1:A100;"=1000")
  • comparaison numérique: par exemple "<100". Une telle formule va faire la somme des cellules qui contiennent un chiffre qui est inférieur à 100. =NB.SI(A1:A100;"<100")
    Remarque: ceci peut s'appliquer également aux dates. Exemple: additionner les valeurs correspondant aux cellules contenant les dates passées =SOMME.SI(A1:A100;"<"&AUJOURDHUI();B1:B100)
  • texte exact: par exemple "Peugeot". Fait la somme des cellules qui correspond aux cellules qui contiennent le texte exact "Peugeot". =SOMME.SI(A1:A100;"Pierre";B1:B100)
  • texte avec les caractères génériques: le caractère "?" remplace exactement un caractère, le caractère "*" remplace un nombre indéfini de caractères. Par exemple la condition "*FR-??" additionnera toutes les cellules qui correspondent aux cellules dont les valeurs se terminent par "FR-" suivi de deux caractères (quelque soient-ils). Le nombre de caractères avant le "FR-" n'a pas d'importance. =SOMME.SI(A1:A100;"*FR-??";B1:B100)
  • référence à une cellule: par exemple "B4". De cette manière, la fonction SOMME.SI additionnera toutes les cellules correspondant aux cellules dont le contenu est égal au contenu de la cellule "B4". =SOMME.SI(A1:A100;B4;B1:B100) Attention, dans la formule, l'adresse de le cellule n'est pas entourée de guillemets!
  • comparaison avec une cellule: c'est l'extension du cas précédent – vous pouvez comparer les valeurs avec la valeur d'une cellule. Vous pouvez utiliser les opérateurs de comparaisons habituels: "<", "<=", ">", ">=". L'opérateur "=" peut être omis (voir le point précédent.
    Attention à la syntaxe: opérateur entouré de guillemets, suivi de signe de concatenation &, suivi de l'adresse de la cellule (sans guillemets). Cela donne donc SOMME.SI(A1:A100;"<=" & C1;B1:B100). Si vous utilisez par exemple "<=C1", votre formule ne fonctionnera pas…

À quoi faire attention lors de l'utilisation de la fonction SOMME.SI

Même si SOMME.SI est plutôt facile à utiliser, il convient de faire attention à certains points qui peuvent créer des problèmes.

  • L'argument contenant la condition de comptage (condition_a_remplir) doit impérativement se trouver entre guillemets. Même s'il s'agit des conditions numériques ( "5" ) ou des expressions qui contiennent un opérateur de comparaison ( "<10" ).
  • Si une des cellules à tester contient une erreur (#VALEUR!), la fonction SOMME.SI renverra comme résultat une erreur également.
  • Si la valeur de comparaison se trouve dans une cellule, vous devez concaténer le signe de comparaison entouré de guillemets ("=", "<", "<=", ">", ">=") avec l'adresse de la cellule. Vous pouvez le faire à l'aide de "&". Donc cela donnera par exemple SOMME.SI(A2:A500;">" & C2) ou SOMME.SI(A2:A500;">" & C2; B2:B500)
  • Si vous voulez utiliser une condition textuelle qui utilise une longue chaîne de caractères (plus de 255 caractères), la fonction va renvoyer une erreur à la place de résultat. Mais il est possible de contourner cette limitation: il suffit de séparer le long texte en parties plus petites (avec moins de 255 caractères chacune) que l'on "recompose" ensuite grâce à l'opérateur de concaténation ( & ).
    Exemple: =SOMME.SI(A1:A1000;"première ... partie" & "seconde ... partie";B1:B1000)
  • Si vous souhaitez utiliser plus qu'une condition pour déterminer les valeurs à additionner, vous pouvez utiliser la fonction SOMME.SI.ENS >> Tutoriel sur l'utilisation de la fonction SOMME.SI.ENS

Pour aller plus loin en Excel…

Et si vous voulez explorer un peu plus les possibilités que vous offre Excel, voici quelques liens comme point de départ…

N'hésitez pas à partager cette page si elle vous a été utile et vous pouvez également laisser un commentaire en cas de questions, remarques ou idées d'amélioration…

Laissez un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

9 commentaires sur “Maîtrisez SOMME.SI en Excel: GUIDE COMPLET avec Exemples”